centos/ubuntu安装uci/libubox/lua

在ubuntu或centos主机上安装uci需要安装libubox,而安装libubox需要lua环境和json-c库,网上很多文章没有提到lua的安装,反正我安装时遇见了依赖lua的错误。

安装lua

先安装lua,我尝试了最新版的lua5.3,libubox不匹配,5.1版本是OK的

下载地址:http://www.lua.org/ftp/

下载后直接make、make install,一般没啥错误。

安装libubox

如果提示没有安装json-c,就先安装以下,网上教程很多,不累述

安装libuci

至此就安装完毕了

libuci和uci命令的使用

先给一个libuci-test.c

libuci-test.c[点击下载]

编译:gcc -o test -g libuci-test.c -luci

uci的命令详解见别人的博客吧:

https://blog.csdn.net/qq_35718410/article/details/53113894

 

发表评论

电子邮件地址不会被公开。 必填项已用*标注